近期很多用户在应用中心安装应用,提示105错误,大部分是阿里云的服务器,PHP 5.3.28、PHP5.3.29等。
通过常规的方法排查后,仍然不能解决问题,官方给出的说明是PHP问题,升级PHP即可,经过测试,确实是PHP问题,升级PHP可以解决。
但不是所有用户都知道如何升级,经过的排查,锁定了引起php5.3执行错误的代码,在大量测试下找到了一种特殊的偏方,解决办法如下:
打开 source\admincp\admincp_cloudaddons.php找到:
  1. if($md5 != md5_file($file)) {
复制代码
修改为:
  1. if('s'.$md5 != 's'.md5_file($file)) {
复制代码
PS:懂技术的请不要问为什么这样改,为什么不那样那样改,你自己测试
原文:https://www.discuz.1314study.com/t/137890.html
回复

使用道具 举报

共收到0条回复

倒序浏览 显示全部楼层
您需要登录后才可以回帖 登录 or 立即注册

本版积分规则

8主题
8帖子
55积分
快速回复 返回顶部 返回列表